]> git.pld-linux.org Git - packages/perl-File-Tail.git/blob - perl-File-Tail.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Tail.git] / perl-File-Tail.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    Tail
7 Summary:        File::Tail Perl module - reading from continuously updated files
8 Summary(pl.UTF-8):      Moduł Perla File::Tail - czytanie z ciągle uaktualnianych plików
9 Name:           perl-File-Tail
10 Version:        0.99.3
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ef0fb7bcb4181ba593f4a09940f61d1c
17 URL:            http://search.cpan.org/dist/File-Tail/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 File::Tail is a Perl tail. The primary purpose of File::Tail is
25 reading and analysing log files while they are being written, which is
26 especialy useful if you are monitoring the logging process with a tool
27 like Tobias Oetiker's MRTG.
28
29 %description -l pl.UTF-8
30 File::Tail to 'tail' dla Perla. Głównym przeznaczeniem modułu jest
31 czytanie i analizowanie plików logów podczas gdy są zapisywane, co
32 jest szczególnie przydatne przy monitorowaniu procesu logowania przy
33 użyciu narzędzi takich jak MRTG Tobiasa Oetikera.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 install logwatch select_demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/File/Tail.pm
61 # empty autosplit.ix
62 #%dir %{perl_vendorlib}/auto/File
63 #%dir %{perl_vendorlib}/auto/File/Tail
64 #%%{perl_vendorlib}/auto/File/Tail/autosplit.ix
65 %{_mandir}/man3/*
66 %dir %{_examplesdir}/%{name}-%{version}
67 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.077655 seconds and 4 git commands to generate.