]> git.pld-linux.org Git - packages/perl-File-Sort.git/blob - perl-File-Sort.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Sort.git] / perl-File-Sort.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    Sort
7 Summary:        File::Sort - sort a file or merge sort multiple files
8 Summary(pl.UTF-8):      File::Sort - sortowanie pliku lub połączenie wyniku sortowania wielu plików
9 Name:           perl-File-Sort
10 Version:        1.01
11 Release:        4
12 # same as perl
13 License:        GPL v1 or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1feb4128bba2edde68ada7838e55863a
17 URL:            http://search.cpan.org/dist/File-Sort/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The File::Sort Perl module sorts text files by lines (or records).
25 Comparisons are based on one or more sort keys extracted from each
26 line of input, and are performed lexicographically. By default, if
27 keys are not given, sort regards each input line as a single field.
28 The sort is a merge sort.
29
30 %description -l pl.UTF-8
31 Moduł Perla File::Sort sortuje pliki tekstowe według wierszy (lub
32 rekordów). Porównania dokonywane są w oparciu o jeden lub więcej
33 kluczy sortowania pobieranych z każdego wiersza danych wejściowych i
34 układane leksykograficznie. Domyślnie, jeśli nie podano klucza,
35 sortowanie dotyczy całych wierszy danych wejściowych jako pojedynczych
36 pól. Wyniki sortowania są łączone.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README eg
60 %{perl_vendorlib}/File/Sort.pm
61 %{_mandir}/man3/*
This page took 0.068481 seconds and 4 git commands to generate.