]> git.pld-linux.org Git - packages/perl-File-Modified.git/blame - perl-File-Modified.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Modified.git] / perl-File-Modified.spec
CommitLineData
021f7bae 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
d6053a9d 4
021f7bae 5%define pdir File
6%define pnam Modified
7Summary: File::Modified - checks intelligently if files have changed
fc9b9a6b 8Summary(pl.UTF-8): File::Modified - inteligentne sprawdzanie, czy pliki uległy zmianie
021f7bae 9Name: perl-File-Modified
10Version: 0.07
0c180b89 11Release: 2
021f7bae 12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 271a991b96ccbdaeb7098272c9f97d51
d6053a9d 17URL: http://search.cpan.org/dist/File-Modified/
021f7bae 18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildArch: noarch
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
e4bfe6f4
JB
24The Modified module is intended as a simple method for programs to
25detect whether configuration files (or modules they rely on) have
26changed. There are currently two methods of change detection
27implemented, mtime and MD5. The MD5 method will fall back to use
28timestamps if the Digest::MD5 module cannot be loaded.
021f7bae 29
e4bfe6f4
JB
30There is another module, File::Signature, which has many similar
31features, so if this module doesn't do what you need, maybe
32File::Signature does. There also is quite some overlap between the two
33modules, code wise.
021f7bae 34
79b18930
JR
35%description -l pl.UTF-8
36Moduł Modified ma służyć programom za prostą metodę sprawdzania czy
37pliki konfiguracyjne (lub moduły na których polegają) się zmieniły.
38Aktualnie są zaimplementowane dwie metody sprawdzania zmian: mtime i
39MD5. Metoda MD5 będzie działać jako mtime jeśli moduł Digest::MD5
40będzie niedostępny.
e4bfe6f4 41
79b18930
JR
42Istnieje inny moduł - File::Signature - mający wiele podobnych cech,
43więc jeśli ten moduł nie jest tym co potrzeba, może File::Signature
44jest. Moduły te pokrywają się częściowo także pod względem kodu.
021f7bae 45
46%prep
47%setup -q -n %{pdir}-%{pnam}-%{version}
48
49%build
50%{__perl} Makefile.PL \
51 INSTALLDIRS=vendor
52%{__make}
53
54%{?with_tests:%{__make} test}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59%{__make} install \
60 DESTDIR=$RPM_BUILD_ROOT
61
62install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc Changes README
71%{perl_vendorlib}/File/*.pm
72%{_mandir}/man3/*
73%{_examplesdir}/%{name}-%{version}
This page took 0.081385 seconds and 4 git commands to generate.