]> git.pld-linux.org Git - packages/perl-File-Listing.git/blob - perl-File-Listing.spec
up to 6.15
[packages/perl-File-Listing.git] / perl-File-Listing.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    File
6 %define         pnam    Listing
7 Summary:        File::Listing - parse directory listing
8 Summary(pl.UTF-8):      File::Listing - analiza listingu katalogu
9 Name:           perl-File-Listing
10 Version:        6.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8ba34641a6c5a2ec1b0bf7064f68c535
17 URL:            https://metacpan.org/release/File-Listing
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-HTTP-Date >= 6
24 BuildRequires:  perl-Test-Simple >= 0.98
25 %endif
26 Requires:       perl-HTTP-Date >= 6
27 Conflicts:      perl-libwww < 6
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module exports a single function called parse_dir(), which can be
33 used to parse directory listings.
34
35 %description -l pl.UTF-8
36 Ten moduł eksportuje jedną funkcję: parse_dir(), służącą do analizy
37 listingów katalogów.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/File/Listing.pm
62 %{_mandir}/man3/File::Listing.3pm*
This page took 0.105685 seconds and 4 git commands to generate.