]> git.pld-linux.org Git - packages/perl-File-HomeDir.git/blob - perl-File-HomeDir.spec
- macros for perl dependency generators
[packages/perl-File-HomeDir.git] / perl-File-HomeDir.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define pdir    File
6 %define pnam    HomeDir
7 Summary:        File::HomeDir - Find your home and other directories, on any platform
8 Summary(pl.UTF-8):      File::HomeDir - określanie katalogu domowego i innych katalogów na dowolnej platformie
9 Name:           perl-File-HomeDir
10 Version:        1.006
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3a59f74d227fdf97b2af908a2d4fee05
17 URL:            https://metacpan.org/dist/File-HomeDir
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl(Cwd) >= 3.12
23 BuildRequires:  perl(File::Path) >= 2.01
24 BuildRequires:  perl(File::Spec) >= 3.12
25 BuildRequires:  perl-File-Temp >= 0.19
26 BuildRequires:  perl-File-Which >= 0.05
27 BuildRequires:  perl-Test-Simple >= 0.47
28 %endif
29 Requires:       perl(Cwd) >= 3.12
30 Requires:       perl(File::Path) >= 2.01
31 Requires:       perl(File::Spec) >= 3.12
32 Requires:       perl-File-Temp >= 0.19
33 Requires:       perl-File-Which >= 0.05
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 File::HomeDir is a module for dealing with issues relating to the
39 location of directories that are "owned" by a user, primarily your
40 user, and to solve these issues consistently across a wide variety of
41 platforms.
42
43 %description -l pl.UTF-8
44 File::HomeDir to moduł do rozwiązywania kwestii związanych z
45 położeniem katalogów należących do użytkownika w sposób spójny dla
46 wielu platform.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes
70 %{perl_vendorlib}/File/HomeDir.pm
71 %{perl_vendorlib}/File/HomeDir
72 %{_mandir}/man3/File::HomeDir*.3pm*
This page took 0.09482 seconds and 4 git commands to generate.