]> git.pld-linux.org Git - packages/perl-File-Find-Rule.git/blob - perl-File-Find-Rule.spec
- macros for perl autodeps
[packages/perl-File-Find-Rule.git] / perl-File-Find-Rule.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    Find-Rule
7 Summary:        File::Find::Rule - alternative interface to File::Find
8 Summary(pl.UTF-8):      File::Find::Rule - alternatywny interfejs dla modułu File::Find
9 Name:           perl-File-Find-Rule
10 Version:        0.34
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a7aa9ad4d8ee87b2a77b8e3722768712
17 URL:            https://metacpan.org/release/File-Find-Rule
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Number-Compare
23 BuildRequires:  perl-Test-Simple
24 BuildRequires:  perl-Text-Glob >= 0.07
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 File::Find::Rule Perl module is a friendlier interface to File::Find.
31 It allows you to build rules which specify the desired files and
32 directories.
33
34 %description -l pl.UTF-8
35 Moduł Perla File::Find::Rule stanowi bardziej przyjazny interfejs do
36 modułu File::Find. Umożliwia on tworzenie reguł określających wymagane
37 pliki i katalogi.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 # get rid of pod documentation
56 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/File/Find/Rule/*.pod
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes
64 %attr(755,root,root) %{_bindir}/findrule
65 %dir %{perl_vendorlib}/File/Find
66 %{perl_vendorlib}/File/Find/Rule.pm
67 # for modules based on File::Find::Rule
68 %dir %{perl_vendorlib}/File/Find/Rule
69 %{_mandir}/man1/findrule.1p*
70 %{_mandir}/man3/File::Find::Rule*.3pm*
This page took 0.06694 seconds and 4 git commands to generate.