]> git.pld-linux.org Git - packages/perl-File-Copy-Recursive.git/blob - perl-File-Copy-Recursive.spec
- updated to 0.45
[packages/perl-File-Copy-Recursive.git] / perl-File-Copy-Recursive.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    File
6 %define pnam    Copy-Recursive
7 Summary:        File::Copy::Recursive - recursively copying files and directories
8 Summary(pl.UTF-8):      File::Copy::Recursive - rekurencyjne kopiowanie plików i katalogów
9 Name:           perl-File-Copy-Recursive
10 Version:        0.45
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e5eee1a3f8ae3aebbac063ea54870e54
17 URL:            https://metacpan.org/release/File-Copy-Recursive
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-File-Temp
23 BuildRequires:  perl-Path-Tiny
24 BuildRequires:  perl-Test-Deep
25 BuildRequires:  perl-Test-Fatal
26 BuildRequires:  perl-Test-File
27 BuildRequires:  perl-Test-Warnings
28 BuildRequires:  perl-Test-Simple >= 0.88
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This module copies and moves directories recursively (or single files,
35 well... singley) to an optional depth and attempts to preserve each
36 file or directory's mode.
37
38 %description -l pl.UTF-8
39 Te moduł kopiuje i przenosi katalogi rekurencyjnie (lub pojedyncze
40 pliki... pojedynczo) do opcjonalnej głębokości i próbuje zachować
41 uprawnienia każdego pliku i katalogu.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README README.md
65 %dir %{perl_vendorlib}/File/Copy
66 %{perl_vendorlib}/File/Copy/Recursive.pm
67 %{_mandir}/man3/File::Copy::Recursive.3pm*
This page took 0.073984 seconds and 4 git commands to generate.