]> git.pld-linux.org Git - packages/perl-File-Copy-Recursive-Reduced.git/blob - perl-File-Copy-Recursive-Reduced.spec
- new
[packages/perl-File-Copy-Recursive-Reduced.git] / perl-File-Copy-Recursive-Reduced.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    File
6 %define         pnam    Copy-Recursive-Reduced
7 Summary:        File::Copy::Recursive::Reduced - recursive copying of files and directories within Perl 5 toolchain
8 Summary(pl.UTF-8):      File::Copy::Recursive::Reduced - rekurencyjne kopiowanie plików i katalogów z poziomu narzędzi Perla 5
9 Name:           perl-File-Copy-Recursive-Reduced
10 Version:        0.006
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a42c7743e4a76f7492d4877ad48d261f
17 URL:            https://metacpan.org/release/File-Copy-Recursive-Reduced
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Capture-Tiny
24 BuildRequires:  perl-Path-Tiny
25 BuildRequires:  perl-Test-Simple >= 0.44
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This library is intended as a not-quite-drop-in replacement for
32 certain functionality provided by CPAN distribution
33 File-Copy-Recursive. The library provides methods similar enough to
34 that distribution's fcopy(), dircopy() and rcopy() functions to be
35 usable in those CPAN distributions often described as being part of
36 the Perl toolchain.
37
38 %description -l pl.UTF-8
39 Ta biblioteka ma być przybliżonym zamiennikiem dla wybranej części
40 funkcjonalności dostarczanej przez dystrybucję CPAN
41 File-Copy-Recursive. Biblioteka dostarcza metody wystarczająco podobne
42 do funkcji fcopy(), dircopy() i rcopy(), aby dało się ich używać w
43 dystrubucjach CPAN opisywanych jako część zestawu narzędzi Perla.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README Todo
67 %dir %{perl_vendorlib}/File/Copy/Recursive
68 %{perl_vendorlib}/File/Copy/Recursive/Reduced.pm
69 %{_mandir}/man3/File::Copy::Recursive::Reduced.3pm*
This page took 0.1169 seconds and 4 git commands to generate.