]> git.pld-linux.org Git - packages/perl-File-ChangeNotify.git/blob - perl-File-ChangeNotify.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-ChangeNotify.git] / perl-File-ChangeNotify.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    File
6 %define pnam    ChangeNotify
7 Summary:        File::ChangeNotify - Watch for changes to files, cross-platform style
8 Summary(pl.UTF-8):      File::ChangeNotify - Obserwuje modyfikację plików
9 Name:           perl-File-ChangeNotify
10 Version:        0.21
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 #Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bd8f8f32faed6aba5353b8f270898935
18 URL:            http://search.cpan.org/dist/File-ChangeNotify/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(MooseX::Params::Validate) >= 0.08
23 BuildRequires:  perl(MooseX::SemiAffordanceAccessor)
24 BuildRequires:  perl-namespace-autoclean
25 BuildRequires:  perl-Class-MOP
26 BuildRequires:  perl-Linux-Inotify2
27 BuildRequires:  perl-Moose
28 # not in PLD, yet
29 #BuildRequires: perl-Test-Without-Module
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module provides an API for creating a File::ChangeNotify::Watcher
36 subclass that will work on your platform.
37
38 Most of the documentation for this distro is in
39 File::ChangeNotify::Watcher.
40
41 %description -l pl.UTF-8
42 Moduł ten dostarcza API do tworzenia podklasy
43 File::ChangeNotify::Watcher która może pracować na Twojej platformie.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 %ifnos bsd
62 # BSD-specific watcher
63 rm $RPM_BUILD_ROOT%{perl_vendorlib}/File/ChangeNotify/Watcher/KQueue.pm
64 rm $RPM_BUILD_ROOT%{_mandir}/man3/File::ChangeNotify::Watcher::KQueue.3pm*
65 %endif
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %{perl_vendorlib}/File/*.pm
74 %{perl_vendorlib}/File/ChangeNotify
75 %{_mandir}/man3/*
This page took 0.075792 seconds and 4 git commands to generate.