]> git.pld-linux.org Git - packages/perl-ExtUtils-LibBuilder.git/blob - perl-ExtUtils-LibBuilder.spec
- new
[packages/perl-ExtUtils-LibBuilder.git] / perl-ExtUtils-LibBuilder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    ExtUtils
6 %define         pnam    LibBuilder
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        ExtUtils::LibBuilder - a tool to build C libraries
9 Summary(pl.UTF-8):      ExtUtils::LibBuilder - narzędzie do budowania bibliotek C
10 Name:           perl-ExtUtils-LibBuilder
11 Version:        0.08
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8ffe9e9a3c2f916f40dc4f6aed237d33
18 URL:            https://metacpan.org/release/ExtUtils-LibBuilder/
19 BuildRequires:  perl-ExtUtils-CBuilder >= 0.23
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Test-Simple
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Some Perl modules need to ship C libraries together with their Perl
31 code. Although there are mechanisms to compile and link (or glue) C
32 code in your Perl programs, there isn't a clear method to compile
33 standard, self-contained C libraries.
34
35 This module main goal is to help in that task.
36
37 %description -l pl.UTF-8
38 Niektóre moduły Perla muszą mieć dołączone do kodu perlowego
39 biblioteki C. O ile są mechanizmy do kompilowania i linkowania (czy
40 sklejania) kodu C do programów w Perlu, to nie ma prostej metody
41 kompilowania standardowej, samodzielnej biblioteki C.
42
43 Głównym celem tego modułu jest pomoc w tym zadaniu.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/ExtUtils/LibBuilder.pm
68 %{_mandir}/man3/ExtUtils::LibBuilder.3pm*
This page took 0.100663 seconds and 4 git commands to generate.