]> git.pld-linux.org Git - packages/perl-ExtUtils-InstallPaths.git/blob - perl-ExtUtils-InstallPaths.spec
- updated to 0.012
[packages/perl-ExtUtils-InstallPaths.git] / perl-ExtUtils-InstallPaths.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    ExtUtils
6 %define         pnam    InstallPaths
7 Summary:        ExtUtils::InstallPaths - Build.PL install path logic made easy
8 Summary(pl.UTF-8):      ExtUtils::InstallPaths - ułatwienie logiki ścieżek instalacyjnych Build.PL
9 Name:           perl-ExtUtils-InstallPaths
10 Version:        0.012
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9a8d66aab1ffec98ea260faf03ac612b
17 URL:            https://metacpan.org/release/ExtUtils-InstallPaths
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl(File::Spec::Functions) >= 0.83
23 BuildRequires:  perl-ExtUtils-Config >= 0.002
24 BuildRequires:  perl-File-Temp
25 BuildRequires:  perl-Test-Simple
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module tries to make install path resolution as easy as possible.
32
33 When you want to install a module, it needs to figure out where to
34 install things. The nutshell version of how this works is that default
35 installation locations are determined from ExtUtils::Config, and they
36 may be individually overridden by using the install_path attribute.
37 An install_base attribute lets you specify an alternative installation
38 root like /home/foo and prefix does something similar in a rather
39 different (and more complicated) way. destdir lets you specify a
40 temporary installation directory like /tmp/install in case you want to
41 create bundled-up installable packages.
42
43 %description -l pl.UTF-8
44 Ten moduł próbuje ułatwić rozwiązywanie ścieżek instalacyjnych na
45 tyle, na ile to możliwe.
46
47 Aby zainstalować moduł, musi on określić, gdzie instalować
48 poszczególne elementy. W skrócie, domyślne ścieżki instalacyjne są
49 określane z ExtUtils::Config i mogą być indywidualnie nadpisywane przy
50 użyciu atrybutu install_path. Atrybut install_base pozwala na
51 określenie alternatywnego korzenia dzewa instalacji, np. /home/foo, a
52 prefix robi coś podobnego w nieco inny (i bardziej skomplikowany)
53 sposób. destdir pozwala określić tymczasowy katalog instalacyjny, na
54 przykład /tmp/install, aby utworzyć pakiety instalacyjne.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} pure_install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes
78 %{perl_vendorlib}/ExtUtils/InstallPaths.pm
79 %{_mandir}/man3/ExtUtils::InstallPaths.3pm*
This page took 0.107662 seconds and 4 git commands to generate.