]> git.pld-linux.org Git - packages/perl-ExtUtils-CChecker.git/blob - perl-ExtUtils-CChecker.spec
- updated to 0.11
[packages/perl-ExtUtils-CChecker.git] / perl-ExtUtils-CChecker.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    ExtUtils
6 %define pnam    CChecker
7 Summary:        ExtUtils::CChecker - configure-time utilities for using C headers, libraries, or OS features
8 Summary(pl.UTF-8):      ExtUtils::CChecker - sprawdzanie nagłówków C, bibliotek i cech OS w czasie konfiguracji
9 Name:           perl-ExtUtils-CChecker
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/P/PE/PEVANS/ExtUtils-CChecker-%{version}.tar.gz
16 # Source0-md5:  6c40b0aa26907aed861288808dee755c
17 URL:            https://metacpan.org/dist/ExtUtils-CChecker
18 BuildRequires:  perl-Module-Build >= 0.4004
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Fatal
23 BuildRequires:  perl-Test-Pod >= 1.00
24 BuildRequires:  perl-Test-Simple >= 0.88
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Often Perl modules are written to wrap functionallity found in
31 existing C headers, libraries, or to use OS-specific features. It is
32 useful in the Build.PL or Makefile.PL file to check for the existance
33 of these requirements before attempting to actually build the module.
34
35 Objects in this class provide an extension around ExtUtils::CBuilder
36 to simplify the creation of a .c file, compiling, linking and running
37 it, to test if a certain feature is present.
38
39 It may also be necessary to search for the correct library to link
40 against, or for the right include directories to find header files in.
41 This class also provides assistance here.
42
43 %description -l pl.UTF-8
44 Często moduły Perla obudowują funkcjonalność istniejących nagłówków C,
45 bibliotek i innych właściwości systemu operacyjnego. Wtedy w pliku
46 Build.PL lub Makefile.PL przydaje się sprawdzić istnienie wymaganych
47 elementów przed próbą właściwego zbudowania modułu.
48
49 Obiekty w tej klasie udostępniają rozszerzenie modułu
50 ExtUtils::CBuilder upraszczające tworzenie pliku .c, kompilację,
51 linkowanie i uruchamianie w celu sprawdzenia istnienia pewnej cechy.
52
53 Moduł może być przydatny także w celu znalezienia właściwej biblioteki
54 lub katalogu z plikami nagłówkowymi do użycia.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Build.PL \
61         destdir=$RPM_BUILD_ROOT \
62         installdirs=vendor
63 ./Build
64
65 %{?with_tests:./Build test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 ./Build install
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorlib}/ExtUtils/CChecker.pm
79 %{_mandir}/man3/ExtUtils::CChecker.3pm*
This page took 0.12982 seconds and 4 git commands to generate.