]> git.pld-linux.org Git - packages/perl-ExtUtils-AutoInstall.git/blob - perl-ExtUtils-AutoInstall.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-ExtUtils-AutoInstall.git] / perl-ExtUtils-AutoInstall.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    ExtUtils
6 %define         pnam    AutoInstall
7 Summary:        ExtUtils::AutoInstall - automatic install of dependencies via CPAN
8 Summary(pl.UTF-8):      ExtUtils::AutoInstall - automatyczna instalacja zależności z CPAN
9 Name:           perl-ExtUtils-AutoInstall
10 Version:        0.63
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  87ce9c44a8ab52e9b0553a2e46805525
17 URL:            http://search.cpan.org/dist/ExtUtils-AutoInstall/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ExtUtils::AutoInstall Perl module lets module writers to specify a
25 more sophisticated form of dependency information than the PREREQ_PM
26 option offered by ExtUtils::MakeMaker.  Most notable features include:
27
28 - Letting the user enable/disable optional dependencies.
29 - Support sane defaults by probing for the machine's capability.
30 - If not inside a cpan shell, use CPAN.pm to install dependencies.
31 - Enable/disable the associated tests automatically.
32 - Supply UNINST=1 when it is safe and possibly needed.
33 - Checks MANIFEST to avoid unnecessary grepping of EXE_FILES.
34 - Utilizes CPANPLUS and/or Sort::Versions where feasible.
35 - Offers check-only and skip-all Makefile.PL targets.
36 - Offers check-only and install-only Makefile targets.
37 - Take advantage of the 'sudo' command where available.
38
39 %description -l pl.UTF-8
40 Moduł Perla ExtUtils::AutoInstall pozwala autorom modułów na
41 udostępnianie informacji o zależnościach w bardziej wyszukanej formie,
42 niż opcja PREREQ_PM obsługiwana przez ExtUtils::MakeMaker. Większość
43 godnych uwagi właściwości to:
44
45 - Umożliwienie użytkownikom na włączanie/wyłączanie zależności
46   opcjonalnych.
47 - Wsparcie dla wartości domyślnych otrzymywanych poprzez sprawdzenie
48   właściwości maszyny.
49 - Korzystanie z CPAN.pm do instalacji zależności w przypadku użycia
50   spoza powłoki cpan.
51 - Automatyczne włączanie/wyłączanie stowarzyszonych testów.
52 - Podanie UNINST=1, gdy jest to bezpieczne i prawdopodobnie potrzebne.
53 - Sprawdzenie MANIFEST, aby uniknąć niepotrzebnego przeszukiwania
54   EXE_FILES.
55 - Wykorzystanie CPANPLUS i/lub Sort::Versions, gdy jest to możliwe.
56 - Udostępnienie celów Makefile.PL check-only i skip-all.
57 - Udostępnienie celów Makefile check-only i install-only.
58 - Wykorzystanie polecenia 'sudo', gdy jest ono dostępne.
59
60 %prep
61 %setup -q -n %{pdir}-%{pnam}-%{version}
62
63 %build
64 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"ExtUtils::AutoInstall")' \
65         INSTALLDIRS=vendor
66 %{__make}
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS Changes README TODO
82 %{perl_vendorlib}/ExtUtils/*.pm
83 %{_mandir}/man3/*
This page took 0.216927 seconds and 4 git commands to generate.