]> git.pld-linux.org Git - packages/perl-Exporter-Lite.git/blob - perl-Exporter-Lite.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Exporter-Lite.git] / perl-Exporter-Lite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Exporter
6 %define         pnam    Lite
7 Summary:        Exporter::Lite - lightweight exporting of variables
8 Summary(pl.UTF-8):      Exporter::Lite - lekkie eksportowanie zmiennych
9 Name:           perl-Exporter-Lite
10 Version:        0.02
11 Release:        1
12 # contains "same as perl" modules for tests
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e2ed5978a09020de16b5cf30c84566b0
17 URL:            http://search.cpan.org/dist/Exporter-Lite/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is an alternative to Exporter intended to provide a lightweight
25 subset of its functionality. It supports import(), @EXPORT and
26 @EXPORT_OK and not a whole lot else.
27
28 Unlike Exporter, it is not necessary to inherit from Exporter::Lite
29 (ie. no @ISA = qw(Exporter::Lite) mantra). Exporter::Lite simply
30 exports its import() function. This might be called a "mix-in".
31
32 %description -l pl.UTF-8
33 Ten moduł jest alternatywą dla Exportera mającą udostępnić lekki
34 podzbiór jego funkcjonalności. Obsługuje import(), @EXPORT oraz
35 @EXPORT_OK i niewiele więcej.
36
37 W przeciwieństwie do Exportera, nie trzeba dziedziczyć z
38 Exporter::Lite (czyli wykonywać mantry @ISA = qw(Exporter::Lite)).
39 Exporter::Lite po prostu eksportuje swoją funkcję import(). Można to
40 nazwać "miksowaniem".
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{perl_vendorlib}/%{pdir}/*.pm
64 %{_mandir}/man3/*
This page took 0.080845 seconds and 4 git commands to generate.