]> git.pld-linux.org Git - packages/perl-Exporter-Easy.git/blob - perl-Exporter-Easy.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Exporter-Easy.git] / perl-Exporter-Easy.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Exporter
6 %define         pnam    Easy
7 Summary:        Exporter::Easy - takes the drudgery out of exporting symbols
8 Summary(pl.UTF-8):      Exporter::Easy - przejmujący harówkę eksportowania symboli
9 Name:           perl-Exporter-Easy
10 Version:        0.16
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  16f44909db2e85578ed2f26db490312b
17 URL:            http://search.cpan.org/dist/Exporter-Easy/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Exporter::Easy gets rid of the drudgery of exporting symbols allowing
25 you to eliminate those bits of code that exists in every single module
26 that uses Exporter.
27
28 It also allows you to define tags in terms of other tags and you no
29 longer have to worry about filling in @EXPORT_OK.
30
31 %description -l pl.UTF-8
32 Exporter::Easy pozwala pozbyć się harówki związanej z eksportowaniem
33 symboli, pozwalając wyeliminować te fragmenty kodu, istniejące w
34 każdym module używającym Exportera.
35
36 Pozwala także na definiowanie znaczników w kontekście innych
37 znaczników, więc nie trzeba się już martwić o wypełnianie @EXPORT_OK.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} -pi -e "s/INSTALLDIRS => 'perl',//" Makefile.PL
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README CHANGES
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{_mandir}/man3/*
This page took 0.118424 seconds and 4 git commands to generate.