]> git.pld-linux.org Git - packages/perl-Event-Lib.git/blob - perl-Event-Lib.spec
perl 5.38.0 rebuild
[packages/perl-Event-Lib.git] / perl-Event-Lib.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4
5 %define pdir    Event
6 %define pnam    Lib
7 Summary:        Event::Lib - Perl extentions for event-based programming
8 Summary(pl.UTF-8):      Event::Lib - rozszerzenie Perla dla programowania opertego na zdarzeniach
9 Name:           perl-Event-Lib
10 Version:        1.04
11 Release:        12
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 #Source0:       http://www.cpan.org/modules/by-module/Event/%{pdir}-%{pnam}-%{version}.tar.gz
15 Source0:        http://search.cpan.org/CPAN/authors/id/C/CR/CRUX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  38bc3b6b9bf44740275dad9198e702fc
17 #URL:           http://search.cpan.org/dist/Event-Lib/
18 URL:            http://search.cpan.org/~crux/Event-Lib/
19 Patch0:         libevent-2.1.patch
20 BuildRequires:  libevent-devel
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       perl-dirs >= 2.1-16
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is a Perl wrapper around libevent(3) as available from
28 <http://www.monkey.org/~provos/libevent/>. It allows to execute a
29 function whenever a given event on a filehandle happens, a timeout
30 occurs or a signal is received.
31
32 Under the hood, one of the available mechanisms for asynchronously
33 dealing with events is used. This could be select, poll, epoll,
34 devpoll or kqueue. The idea is that you don't have to worry about
35 those details and the various interfaces they offer. Event::Lib offers
36 a unified interface to all of them.
37
38 %description -l pl.UTF-8
39 Moduł ten jest perlowym opakowaniem biblioteki libevent(3) dostępnej
40 pod adresem <http://www.monkey.org/~provos/libevent/>. Pozwala na
41 wywołanie funkcji w przypadku określonego zdarzenia na uchwycie pliku,
42 upłynięcia limitu czasu lub odebrania sygnału.
43
44 Wewnątrz używany jest jeden z dostępnych mechanizmów do
45 asynchronicznej obsługi zdarzeń - może to być select, poll, epoll,
46 devpoll lub kqueue. Idea jest taka, że programista nie musi martwić
47 się o szczegóły związane z każdym z tych interfejsów. Event::Lib
48 oferuje ujednolicony interfejs do nich wszystkich.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52 %patch0 -p1
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make} \
58         CC="%{__cc}" \
59         OPTIMIZE="%{rpmcflags}"
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} pure_install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %{perl_vendorarch}/Event/Lib.pm
76 %dir %{perl_vendorarch}/auto/Event/Lib
77 %attr(755,root,root) %{perl_vendorarch}/auto/Event/Lib/Lib.so
78 %{_mandir}/man3/Event::Lib.3pm*
This page took 0.094706 seconds and 4 git commands to generate.