]> git.pld-linux.org Git - packages/perl-Encode-Locale.git/blob - perl-Encode-Locale.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Encode-Locale.git] / perl-Encode-Locale.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Encode
6 %define         pnam    Locale
7 Summary:        Encode::Locale - Determine the locale encoding
8 Summary(pl.UTF-8):      Encode::Locale - określenie kodowania lokalizacji
9 Name:           perl-Encode-Locale
10 Version:        1.05
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Encode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fcfdb8e4ee34bcf62aed429b4a23db27
17 URL:            http://search.cpan.org/dist/Encode-Locale/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Encode >= 2
22 %endif
23 Requires:       perl-Encode >= 2.44-2
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Encode::Locale module looks up the charset and encoding (called a
29 CODESET in the locale jargon) and arrange for the Encode module to
30 know this encoding under the name "locale". It means bytes obtained
31 from the environment can be converted to Unicode strings by calling
32 Encode::encode(locale => $bytes) and converted back again with
33 Encode::decode(locale => $string).
34
35 %description -l pl.UTF-8
36 Moduł Encode::Locale sprawdza zestaw znaków i kodowanie (nazywane
37 CODESET) i przygotowuje je dla modułu Encode pod nazwą "locale".
38 To oznacza, że tekst zakodowany bajtowo może być przekonwertowany do
39 Unikodu przez wywołanie Encode::encode(locale => $bytes) i z powrotem
40 przez Encode::decode(locale => $string).
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/Encode/Locale.pm
65 %{_mandir}/man3/Encode::Locale.3pm*
This page took 0.087228 seconds and 4 git commands to generate.