]> git.pld-linux.org Git - packages/perl-Encode-Detect.git/blob - perl-Encode-Detect.spec
perl 5.38.0 rebuild
[packages/perl-Encode-Detect.git] / perl-Encode-Detect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Encode
6 %define pnam    Detect
7 Summary:        Encode::Detect - An Encode::Encoding subclass that detects the encoding of data
8 Summary(pl.UTF-8):      Encode::Detect - podklasa Encode::Encoding wykrywająca kodowanie danych
9 Name:           perl-Encode-Detect
10 Version:        1.01
11 Release:        17
12 License:        MPL 1.1
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Encode/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  ee9faf55d7105c97b02b8ebe590819c7
16 URL:            http://search.cpan.org/dist/Encode-Detect/
17 BuildRequires:  perl-ExtUtils-CBuilder
18 BuildRequires:  perl-Module-Build >= 0.2808
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Data-Dump
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This Perl module is an Encode::Encoding subclass that uses
28 Encode::Detect::Detector to determine the charset of the input data
29 and then decodes it using the encoder of the detected charset.
30
31 It is similar to Encode::Guess, but does not require the configuration
32 of a set of expected encodings. Like Encode::Guess, it only supports
33 decoding - it cannot encode.
34
35 %description -l pl.UTF-8
36 Ten moduł Perla jest podklasą Encode::Encoding wykorzystującą
37 Encode::Detect::Detector do określenia zestawu znaków danych
38 wejściowych i dekodującą je przy użyciu kodera dla wykrytego zestawu
39 znaków.
40
41 Moduł ten jest podobny do Encode::Guess, ale nie wymaga konfiguracji
42 zbioru oczekiwanych kodowań. Podobnie jak Encode::Guess obsługuje
43 tylko dekodowanie; nie potrafi kodować.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         --extra-compiler-flags='%{rpmcflags} -x c++ -Iinclude' \
51         --destdir=$RPM_BUILD_ROOT \
52         --installdirs=vendor
53 ./Build
54
55 %{?with_tests:./Build test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 ./Build install
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes
68 %{perl_vendorarch}/Encode/*.pm
69 %{perl_vendorarch}/Encode/Detect
70 %dir %{perl_vendorarch}/auto/Encode/Detect
71 %dir %{perl_vendorarch}/auto/Encode/Detect/Detector
72 %attr(755,root,root) %{perl_vendorarch}/auto/Encode/Detect/Detector/*.so
73 %{_mandir}/man3/*
This page took 0.161403 seconds and 4 git commands to generate.