]> git.pld-linux.org Git - packages/perl-Email-Simple.git/blob - perl-Email-Simple.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Email-Simple.git] / perl-Email-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Email
6 %define         pnam    Simple
7 Summary:        Email::Simple - email handling, simply
8 Summary(pl.UTF-8):      Email::Simple - obsługa poczty elektronicznej, po prostu
9 Name:           perl-Email-Simple
10 Version:        2.216
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Email/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9520e2073ca7f3bffb3282f6e6e3dc3f
18 URL:            http://search.cpan.org/dist/Email-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %{?with_tests:BuildRequires:    perl-Email-Date-Format}
22 Obsoletes:      perl-Email-Simple-Creator
23 Requires:       perl-Email-Date-Format
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Email::Simple is the first deliverable of the "Perl Email Project", a
29 reaction against the complexity and increasing bugginess of the
30 Mail::* modules. In contrast, Email::* modules are meant to be simple
31 to use and to maintain, pared to the bone, fast, minimal in their
32 external dependencies, and correct.
33
34 Methods are deliberately kept to a minimum. This is meant to be
35 simple. No, I will not add method X. This is meant to be simple. Why
36 doesn't it have feature Y? Because it's meant to be simple.
37
38 %description -l pl.UTF-8
39 Email::Simple to pierwszy produkt projektu "Perl Email Project",
40 będącego reakcją na złożoność i rosnący współczynnik zapluskwienia
41 modułów Mail::*. W przeciwieństwie do Mail::*, moduły Email::* mają
42 być proste w użyciu i w utrzymaniu, jednocześnie być szybkie i mieć
43 minimalne zależności, a także być poprawne.
44
45 Metody są rozmyślnie utrzymywane w minimalnej liczbie. To ma być
46 proste. Nie, nie dodamy metody X. To ma być proste. Dlaczego nie ma to
47 możliwości Y? Ponieważ to ma być proste.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %{__perl} -pi -e 's/(use 5.005)(03;)/$1_$2/' lib/Email/Simple.pm
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes
73 %{perl_vendorlib}/Email/Simple.pm
74 %{perl_vendorlib}/Email/Simple/*.pm
75 %{_mandir}/man3/Email::Simple*.3pm*
This page took 0.079094 seconds and 4 git commands to generate.