]> git.pld-linux.org Git - packages/perl-EV.git/blob - perl-EV.spec
perl 5.38.0 rebuild
[packages/perl-EV.git] / perl-EV.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # perform "make test"
4
5 %define         pdir    EV
6 Summary:        EV - Perl interface to libev, a high performance full-featured event loop
7 Summary(pl.UTF-8):      EV - perlowy interfejs do libev - wydajnej pętli zdarzeń
8 Name:           perl-EV
9 Version:        4.33
10 Release:        4
11 Epoch:          1
12 # same as Perl, libev: BSD-like
13 License:        GPL v1+ or Artistic (Perl module), BSD-like (embedded libev)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  b6d348e9306fd78dab0b80c55e9efb32
17 URL:            https://metacpan.org/dist/EV
18 BuildRequires:  perl-Canary-Stability
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.52
20 BuildRequires:  perl-common-sense
21 BuildRequires:  perl-devel >= 1:5.8.2
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 Conflicts:      perl-AnyEvent < 5.29
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides an interface to libev
29 <http://software.schmorp.de/pkg/libev.html>.
30
31 This module is very fast and scalable. It is actually so fast that you
32 can use it through the AnyEvent module, stay portable to other event
33 loops (if you don't rely on any watcher types not available through
34 it) and still be faster than with any other event loop currently
35 supported in Perl.
36
37 %description -l pl.UTF-8
38 Moduł ten dostarcza intefejs do libev
39 <http://software.schmorp.de/pkg/libev.html>.
40
41 Jest bardzo szybki i skalowalny. Właściwie jest na tyle szybki, że
42 można go użyć poprzez moduł AnyEvent i pozostawić kod przenośnym na
43 inne pętle zdarzeń (jeśli nie jest wymagane użycie typów obserwatorów
44 niedostępnych przez AnyEvent), i całość jest nadal szybsza niż inne
45 pętle zdarzeń dostępne z poziomu Perla.
46
47 %prep
48 %setup -q -n %{pdir}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor </dev/null
53 %{__make} \
54         CC="%{__cc}" \
55         OPTIMIZE="%{rpmcflags}"
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 install -d libev-doc
66 %{__mv} libev/{Changes,LICENSE,README} libev-doc
67 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/EV/libev.pod
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes COPYING README libev-doc
75 %dir %{perl_vendorarch}/EV
76 %{perl_vendorarch}/EV/*.pm
77 %{perl_vendorarch}/EV.pm
78 %{perl_vendorarch}/EV/EVAPI.h
79 %{perl_vendorarch}/EV/ev.h
80 %dir %{perl_vendorarch}/auto/EV
81 %attr(755,root,root) %{perl_vendorarch}/auto/EV/EV.so
82 %{_mandir}/man3/EV*.3pm*
This page took 0.102862 seconds and 4 git commands to generate.