]> git.pld-linux.org Git - packages/perl-Dir-Self.git/blob - perl-Dir-Self.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Dir-Self.git] / perl-Dir-Self.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Dir
6 %define         pnam    Self
7 Summary:        Dir::Self - a __DIR__ constant for the directory your source file is in
8 Summary(pl.UTF-8):      Dir::Self - stała __DIR__ dla katalogu, w którym znajduje się plik źródłowy
9 Name:           perl-Dir-Self
10 Version:        0.11
11 Release:        1
12 # same as perl 5.8.8+
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Dir/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e484446c3aa042737c0b7cbd0fb2f904
17 URL:            http://search.cpan.org/dist/Dir-Self/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.48
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Perl has two pseudo-constants describing the current location in your
29 source code, __FILE__ and __LINE__. This module adds __DIR__, which
30 expands to the directory your source file is in, as an absolute
31 pathname.
32
33 %description -l pl.UTF-8
34 Perl ma dwie pseudo-stałe opisujące aktualne położenie kodu
35 źródłowego: __FILE__ i __LINE__. Ten moduł dodaje __DIR__, rozwijającą
36 się do katalogu, w którym znajduje się plik źródłowy, w postaci
37 ścieżki bezwzględnej.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/Dir/Self.pm
62 %{_mandir}/man3/Dir::Self.3pm*
This page took 0.076342 seconds and 3 git commands to generate.