]> git.pld-linux.org Git - packages/perl-Dir-Self.git/blame - perl-Dir-Self.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Dir-Self.git] / perl-Dir-Self.spec
CommitLineData
9b748fb1
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Dir
6%define pnam Self
9b748fb1
JB
7Summary: Dir::Self - a __DIR__ constant for the directory your source file is in
8Summary(pl.UTF-8): Dir::Self - stała __DIR__ dla katalogu, w którym znajduje się plik źródłowy
9Name: perl-Dir-Self
10Version: 0.11
11Release: 1
12# same as perl 5.8.8+
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Dir/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: e484446c3aa042737c0b7cbd0fb2f904
17URL: http://search.cpan.org/dist/Dir-Self/
18BuildRequires: perl-ExtUtils-MakeMaker >= 6.48
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-Test-Simple
23%endif
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Perl has two pseudo-constants describing the current location in your
29source code, __FILE__ and __LINE__. This module adds __DIR__, which
30expands to the directory your source file is in, as an absolute
31pathname.
32
33%description -l pl.UTF-8
34Perl ma dwie pseudo-stałe opisujące aktualne położenie kodu
35źródłowego: __FILE__ i __LINE__. Ten moduł dodaje __DIR__, rozwijającą
36się do katalogu, w którym znajduje się plik źródłowy, w postaci
37ścieżki bezwzględnej.
38
39%prep
40%setup -q -n %{pdir}-%{pnam}-%{version}
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make}
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} pure_install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Changes README
61%{perl_vendorlib}/Dir/Self.pm
62%{_mandir}/man3/Dir::Self.3pm*
This page took 0.082327 seconds and 4 git commands to generate.