]> git.pld-linux.org Git - packages/perl-Digest-Whirlpool.git/blob - perl-Digest-Whirlpool.spec
perl 5.38.0 rebuild
[packages/perl-Digest-Whirlpool.git] / perl-Digest-Whirlpool.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Digest
6 %define pnam    Whirlpool
7 Summary:        Digest::Whirlpool - A 512-bit, collision-resistant, one-way hash function
8 Summary(pl.UTF-8):      Digest::Whirlpool - 512-bitowa, odporna na kolizje, jednokierunkowa funkcja skrótu
9 Name:           perl-Digest-Whirlpool
10 Version:        2.04
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b3f1c042e2ab3226a71cc51a07b3f66a
17 URL:            http://search.cpan.org/dist/Digest-Whirlpool/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl-Module-Install
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides an interface to the WHIRLPOOL hash algorithm. This module
25 subclasses Digest::base and can be used either directly or through
26 the Digest meta-module. Using the latter is recommended.
27
28 %description -l pl.UTF-8
29 Moduł ten udostępnia interfejs do algorytmu mieszania WHIRLPOOL.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %{__sed} -i -e '1s|#!/usr/bin/env perl$|#!%{__perl}|' script/whirlpoolsum
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %attr(755,root,root) %{_bindir}/*
58 %{perl_vendorarch}/Digest/*.pm
59 %dir %{perl_vendorarch}/auto/Digest/Whirlpool
60 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/Whirlpool/*.so
61 %{_mandir}/man?/*
This page took 0.125026 seconds and 4 git commands to generate.