]> git.pld-linux.org Git - packages/perl-Digest-SHA1.git/blob - perl-Digest-SHA1.spec
perl 5.38.0 rebuild
[packages/perl-Digest-SHA1.git] / perl-Digest-SHA1.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Digest
6 %define         pnam    SHA1
7 Summary:        Digest::SHA1 - interface to the SHA-1 algorithm
8 Summary(pl.UTF-8):      Digest::SHA1 - interfejs do algorytmu SHA-1
9 Name:           perl-Digest-SHA1
10 Version:        2.13
11 Release:        16
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bd22388f268434f2b24f64e28bf1aa35
17 Patch0:         %{name}-reset.patch
18 URL:            https://metacpan.org/dist/Digest-SHA1
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Digest::SHA1 Perl module allows you to use the NIST SHA-1 message
26 digest algorithm from within Perl programs.  The algorithm takes as
27 input a message of arbitrary length and produces as output a 160-bit
28 "fingerprint" or "message digest" of the input.
29
30 %description -l pl.UTF-8
31 Moduł Perla Digest::SHA1 pozwala używać algorytmu skrótu NIST SHA-1 z
32 programów w Perlu. Algorytm pobiera z wejścia wiadomość dowolnej
33 długości, a na wyjściu produkuje 160-bitowy "odcisk palca" lub "skrót
34 wiadomości" z wejścia.
35
36 %description -l pt_BR.UTF-8
37 Este módulos Perl permite a utilização do algoritmo de digest de
38 mensagens NIST SHA-1 em programas Perl.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %patch0 -p1
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README fip180-1.{gif,html}
65 %{perl_vendorarch}/Digest/SHA1.pm
66 %dir %{perl_vendorarch}/auto/Digest/SHA1
67 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/SHA1/SHA1.so
68 %{_mandir}/man3/Digest::SHA1.3pm*
This page took 0.114497 seconds and 4 git commands to generate.