]> git.pld-linux.org Git - packages/perl-Digest-MD2.git/blob - perl-Digest-MD2.spec
perl 5.38.0 rebuild
[packages/perl-Digest-MD2.git] / perl-Digest-MD2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %define         pdir    Digest
6 %define         pnam    MD2
7 Summary:        Digest::MD2 - MD2 digest algorithm implementation
8 Summary(pl.UTF-8):      Digest::MD2 - implementacja algorytmu skrótu MD2
9 Name:           perl-Digest-MD2
10 Version:        2.04
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cdb34485ef5c345f40d8aae016a00ff6
17 URL:            http://search.cpan.org/dist/Digest-MD2/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The Digest::MD2 module allows you to use the RSA Data Security Inc.
24 MD2 Message Digest algorithm from within Perl programs. The algorithm
25 takes as input a message of arbitrary length and produces as output a
26 128-bit "fingerprint" or "message digest" of the input. The algorithm
27 is described in RFC 1319.
28
29 %description -l pl.UTF-8
30 Moduł Digest::MD2 pozwala na używanie algorytmu skrótu MD2 firmy RSA
31 Data Security Inc. w programach perlowych. Algorytm przyjmuje na
32 wejściu tekst o dowolnej długości, a produkuje na wyjściu 128-bitowy
33 "odcisk palca" lub "skrót" informacji wejściowej. Algorytm jest
34 opisany w RFC 1319.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Digest/MD2.pm
61 %dir %{perl_vendorarch}/auto/Digest/MD2
62 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/MD2/MD2.so
63 %{_mandir}/man3/*
This page took 0.155075 seconds and 4 git commands to generate.