]> git.pld-linux.org Git - packages/perl-Devel-SmallProf.git/blob - perl-Devel-SmallProf.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Devel-SmallProf.git] / perl-Devel-SmallProf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Devel
6 %define         pnam    SmallProf
7 Summary:        Devel::SmallProf - per-line Perl profiler
8 Summary(pl.UTF-8):      Devel::SmallProf - system wspomagania programowania w Perlu
9 Name:           perl-Devel-SmallProf
10 Version:        2.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  498704ed1b888fc62b0c7092f8b590f5
17 URL:            http://search.cpan.org/dist/Devel-SmallProf/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Devel::SmallProf profiler is focused on the time taken for a
25 program run on a line-by-line basis. It is intended to be as "small"
26 in terms of impact on the speed and memory usage of the profiled
27 program as possible and also in terms of being simple to use.
28
29 %description -l pl.UTF-8
30 System wspomagania programowania w Perlu Devel::SmallProf jest
31 zogniskowany na ilość czasu, potrzebnego na wykonanie poszczególnych
32 wierszy programu. Powinien on być na tyle mały, aby, o ile to możliwe,
33 nie wpływał na szybkość i zużycie pamięci analizowanego programu.
34 Powinien być też prosty w użyciu.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README TODO
58 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
59 %{_mandir}/man3/*
This page took 0.068207 seconds and 4 git commands to generate.