]> git.pld-linux.org Git - packages/perl-Devel-FindPerl.git/blob - perl-Devel-FindPerl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Devel-FindPerl.git] / perl-Devel-FindPerl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Devel
6 %define         pnam    FindPerl
7 Summary:        Find the path to the current Perl interpreter
8 Name:           perl-Devel-FindPerl
9 Version:        0.012
10 Release:        1
11 License:        GPL+ or Artistic
12 Group:          Development/Libraries
13 Source0:        http://www.cpan.org/authors/id/L/LE/LEONT/Devel-FindPerl-%{version}.tar.gz
14 # Source0-md5:  d1184cf3a5b3b3d06f75f40944934714
15 URL:            http://search.cpan.org/dist/Devel-FindPerl/
16 BuildRequires:  perl(Exporter) >= 5.57
17 BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module tries to find the path to the currently running perl.
25
26 %prep
27 %setup -q -n %{pdir}-%{pnam}-%{version}
28
29 %build
30 %{__perl} Makefile.PL \
31         INSTALLDIRS=vendor
32 %{__make}
33 %{?with_tests:%{__make} test}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %{__make} pure_install \
38         DESTDIR=$RPM_BUILD_ROOT
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc Changes LICENSE README
46 %{perl_vendorlib}/Devel/FindPerl.pm
47 %{_mandir}/man3/Devel::FindPerl.3pm*
This page took 0.065969 seconds and 4 git commands to generate.