]> git.pld-linux.org Git - packages/perl-Devel-Cycle.git/blob - perl-Devel-Cycle.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Devel-Cycle.git] / perl-Devel-Cycle.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Devel
6 %define pnam    Cycle
7 Summary:        Devel::Cycle - Find memory cycles in objects
8 Summary(pl.UTF-8):      Devel::Cycle - znajdowanie cykli pamięci w obiektach
9 Name:           perl-Devel-Cycle
10 Version:        1.12
11 Release:        1
12 # same as perl 5 >= 5.8.2
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Devel/Devel-Cycle-%{version}.tar.gz
16 # Source0-md5:  3d9a963da87b17398fab9acbef63f277
17 URL:            http://search.cpan.org/dist/Devel-Cycle/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Suggests:       perl-PadWalker
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a simple developer's tool for finding circular references in
26 objects and other types of references. Because of Perl's
27 reference-count based memory management, circular references will
28 cause memory leaks.
29
30 Suggested packages:
31  - perl-PadWalker - If the PadWalker module is installed, Devel::Cycle
32    will also report cycles in code closures.
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera proste narzędzie dla programisty do znajdowania
36 zapętlonych odniesień w obiektach i innych rodzajach referencji. W
37 wyniku perlowego zarządzania pamięcią opartego o zliczanie odniesień
38 zapętlone odniesienia powodują wycieki pamięci.
39
40 Sugerowane pakiety:
41  - perl-PadWalker - Po zainstalowaniu modułu PadWalker, Devel::Cycle
42    będzie w stanie zgłaszać pętle w zagnieżdżonym kodzie.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/Devel/Cycle.pm
67 %{_mandir}/man3/Devel::Cycle.3pm*
This page took 0.072094 seconds and 4 git commands to generate.