]> git.pld-linux.org Git - packages/perl-Devel-CheckLib.git/blob - perl-Devel-CheckLib.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Devel-CheckLib.git] / perl-Devel-CheckLib.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    CheckLib
7 Summary:        Devel::CheckLib - check that a library is available
8 Summary(pl.UTF-8):      Devel::CheckLib - sprawdzanie dostępności biblioteki
9 Name:           perl-Devel-CheckLib
10 Version:        1.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c20873798591176283f51af4ad8088cd
17 URL:            http://search.cpan.org/dist/Devel-CheckLib/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-IO-CaptureOutput >= 1.0801
22 BuildRequires:  perl-Mock-Config >= 0.02
23 BuildRequires:  perl-Test-Simple >= 0.62
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Devel::CheckLib is a Perl module that checks whether a particular C
30 library and its headers are available.
31
32 %description -l pl.UTF-8
33 Devel::CheckLib to moduł Perla sprawdzający, czy dana biblioteka C i
34 jej pliki nagłówkowe są dostępne.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 # remove deprecated script and its man page
53 %{__rm} $RPM_BUILD_ROOT%{_bindir}/use-devel-checklib
54 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/use-devel-checklib.1*
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES README TODO
62 %{perl_vendorlib}/Devel/CheckLib.pm
63 %{_mandir}/man3/Devel::CheckLib.3pm*
This page took 0.082999 seconds and 4 git commands to generate.