]> git.pld-linux.org Git - packages/perl-Devel-CheckBin.git/blob - perl-Devel-CheckBin.spec
- macros for perl autodeps
[packages/perl-Devel-CheckBin.git] / perl-Devel-CheckBin.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    CheckBin
7 Summary:        Devel::CheckBin - check that a command is available
8 Summary(pl.UTF-8):      Devel::CheckBin - sprawdzanie dostępności polecenia
9 Name:           perl-Devel-CheckBin
10 Version:        0.04
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  042b68e48d9b53de7d3ef4c726d57cb2
17 URL:            https://metacpan.org/release/Devel-CheckBin
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.64
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Simple >= 0.98
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Devel::CheckBin is a Perl module that checks whether a particular
30 command is available.
31
32 %description -l pl.UTF-8
33 Devel::CheckBin to moduł Perla sprawdzający, czy dane polecenie jest
34 dostępne.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %{perl_vendorlib}/Devel/CheckBin.pm
60 %{_mandir}/man3/Devel::CheckBin.3pm*
This page took 0.079195 seconds and 4 git commands to generate.