]> git.pld-linux.org Git - packages/perl-Desktop-Notify.git/blob - perl-Desktop-Notify.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Desktop-Notify.git] / perl-Desktop-Notify.spec
1 # TODO
2 # - tests fail, likely need dbus server or sth
3 #
4 # Conditional build:
5 %bcond_with     tests           # do not perform "make test"
6
7 %define         pdir    Desktop
8 %define         pnam    Notify
9 Summary:        Desktop::Notify - Communicate with the Desktop Notifications framework
10 Name:           perl-Desktop-Notify
11 Version:        0.03
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/S/SA/SACAVILIA/Desktop-Notify-%{version}.tar.gz
17 # Source0-md5:  8847fe21dcd8572fec8c4e5f082aa24d
18 URL:            http://search.cpan.org/dist/Desktop-Notify/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Accessor
23 BuildRequires:  perl-Net-DBus
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides a Perl interface to the Desktop Notifications
30 framework.
31
32 The framework allows applications to display pop-up notifications on
33 an X desktop. This is implemented with two components: a daemon that
34 displays the notifications, and a client library used by applications
35 to send notifications to the daemon. These components communicate
36 through the DBus message bus protocol.
37
38 More information is available from
39 <http://trac.galago-project.org/wiki/DesktopNotifications>
40
41 This module serves the same purpose as libnotify, in an
42 object-oriented Perl interface. It is not, however, an interface to
43 libnotify itself, but a separate implementation of the specification
44 using Net::DBus.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %dir %{perl_vendorlib}/Desktop
69 %{perl_vendorlib}/Desktop/*.pm
70 %{perl_vendorlib}/Desktop/Notify
71 %{_mandir}/man3/*
This page took 0.092173 seconds and 4 git commands to generate.