]> git.pld-linux.org Git - packages/perl-DateTime-Format-Builder.git/blob - perl-DateTime-Format-Builder.spec
- updated to 0.83
[packages/perl-DateTime-Format-Builder.git] / perl-DateTime-Format-Builder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DateTime
6 %define pnam    Format-Builder
7 Summary:        DateTime::Format::Builder - Create DateTime parser classes and objects
8 Summary(pl.UTF-8):      DateTime::Format::Builder - tworzenie klas i obiektów analizatorów DateTime
9 Name:           perl-DateTime-Format-Builder
10 Version:        0.83
11 Release:        1
12 Epoch:          1
13 License:        Artistic v2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aa41917ca9ad69b3898728ce9c2fb477
17 URL:            https://metacpan.org/release/DateTime-Format-Builder
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-DateTime >= 1.0.0
24 BuildRequires:  perl-DateTime-Format-Strptime >= 1.04
25 BuildRequires:  perl-Params-Validate >= 0.72
26 BuildRequires:  perl-Scalar-List-Utils
27 BuildRequires:  perl-Test-Simple >= 0.96
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 DateTime::Format::Builder creates DateTime parsers. Many string
34 formats of dates and times are simple and just require a basic
35 regular expression to extract the relevant information. Builder
36 provides a simple way to do this without writing reams of structural
37 code.
38
39 Builder provides a number of methods, most of which you'll never need,
40 or at least rarely need. They're provided more for exposing of the
41 module's innards to any subclasses, or for when you need to do
42 something slightly beyond what I expected.
43
44 %description -l pl.UTF-8
45 DateTime::Format::Builder tworzy analizatory DateTime. Wiele formatów
46 łańcuchów dat i czasu jest prostych i do wyciągnięcia istotnych
47 informacji wymaga jedynie prostego wyrażenia regularnego. Builder
48 udostępnia prosty sposób wykonania tego bez pisania większego kodu
49 strukturalnego.
50
51 Builder udostępnia wiele metod, z których większości się nie używa lub
52 używa bardzo rzadko. Są udostępnione bardziej dla ukazania wnętrzności
53 modułu dla podklas albo w razie potrzeby zrobienia czegoś więcej niż
54 oczekiwał autor.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75
76 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/Format/Builder/Tutorial.pod
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README.md
84 %{perl_vendorlib}/DateTime/Format/Builder.pm
85 %{perl_vendorlib}/DateTime/Format/Builder
86 %{_mandir}/man3/DateTime::Format::Builder*.3pm*
87 %{_examplesdir}/%{name}-%{version}
This page took 0.115387 seconds and 3 git commands to generate.