]> git.pld-linux.org Git - packages/perl-Data-Uniqid.git/commitdiff
- initial auto/th/perl-Data-Uniqid-0.12-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 10 Jul 2018 07:25:58 +0000 (09:25 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 10 Jul 2018 07:25:58 +0000 (09:25 +0200)
perl-Data-Uniqid.spec [new file with mode: 0644]

diff --git a/perl-Data-Uniqid.spec b/perl-Data-Uniqid.spec
new file mode 100644 (file)
index 0000000..2cea895
--- /dev/null
@@ -0,0 +1,59 @@
+#
+# Conditional build:
+%bcond_without tests           # do not perform "make test"
+#
+%define                pdir    Data
+%define                pnam    Uniqid
+%include       /usr/lib/rpm/macros.perl
+Summary:       Data::Uniqid - Perl extension for simple genrating of unique id's
+Name:          perl-Data-Uniqid
+Version:       0.12
+Release:       1
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 6bab3b5da09fedfdf60ce2629a7367db
+URL:           https://metacpan.org/release/Data-Uniqid/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+%endif
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Data::Uniqid provides three simple routines for generating unique ids.
+These ids are coded with a Base62 systen to make them short and handy
+(e.g. to use it as part of a URL).
+
+suinqid genrates a very short id valid only for the localhost and with
+a liftime of 1 day
+
+uniqid generates a short id valid on the local host
+
+luniqid generates a long id valid everywhere and ever
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_vendorlib}/Data/Uniqid.pm
+%{_mandir}/man3/Data::Uniqid.3*
This page took 0.09588 seconds and 4 git commands to generate.