]> git.pld-linux.org Git - packages/perl-Data-Page.git/blob - perl-Data-Page.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Page.git] / perl-Data-Page.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Data
6 %define         pnam    Page
7 Summary:        Data::Page - help when paging through sets of results
8 Summary(pl.UTF-8):      Data::Page - pomoc przy stronicowaniu zbiorów wyników
9 Name:           perl-Data-Page
10 Version:        2.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bd1fb9f7d69bf804132201c3e6a1c80a
17 URL:            http://search.cpan.org/dist/Data-Page/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Accessor-Chained
23 BuildRequires:  perl-Test-Exception
24 %endif
25 Requires:       perl-Class-Accessor-Chained
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 When searching through large amounts of data, it is often the case
31 that a result set is returned that is larger than we want to display
32 on one page. This results in wanting to page through various pages of
33 data. The maths behind this is unfortunately fiddly, hence this
34 module.
35
36 The main concept is that you pass in the number of total entries, the
37 number of entries per page, and the current page number. You can then
38 call methods to find out how many pages of information there are, and
39 what number the first and last entries on the current page really are.
40
41 %description -l pl.UTF-8
42 Przy przeszukiwaniu dużych ilości danych zwykle zwracany zbiór wyników
43 jest większy niż chcielibyśmy wyświetlić na jednej stronie. Powoduje
44 to chęć podzielenia danych na strony. Obliczenia przy tym są niestety
45 nietrywialne i stąd ten moduł.
46
47 Główną ideą jest to, że przekazuje się liczbę wszystkich elementów,
48 liczbę elementów na stronie i aktualny numer strony. Można wtedy
49 wywoływać metody, aby określić liczbę stron z informacjami oraz numer
50 pierwszego i ostatniego elementu na aktualnej stronie.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %{perl_vendorlib}/Data/Page.pm
75 %{_mandir}/man3/*
This page took 0.101526 seconds and 4 git commands to generate.