]> git.pld-linux.org Git - packages/perl-Data-Compare.git/blob - perl-Data-Compare.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Compare.git] / perl-Data-Compare.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    Compare
7 Summary:        Data::Compare - compare Perl data structures
8 Summary(pl.UTF-8):      Data::Compare - porównywanie struktur danych w Perlu
9 Name:           perl-Data-Compare
10 # fill to four decimal digits to avoid epoch bumps after 1.2102
11 %define ver     1.25
12 Version:        %{ver}00
13 Release:        1
14 Epoch:          1
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{ver}.tar.gz
19 # Source0-md5:  6a397ab5833237f3ca05ed7277b19a7a
20 URL:            http://search.cpan.org/dist/Data-Compare/
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  perl-devel >= 1:5.8.0
23 %if %{with tests}
24 BuildRequires:  perl-File-Find-Rule >= 0.11
25 BuildRequires:  perl-Scalar-Properties
26 BuildRequires:  perl-perldoc
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Data::Compare module compares two Perl data structures recursively.
33
34 %description -l pl.UTF-8
35 Moduł Data::Compare służy do rekurencyjnego porównywania dwóch
36 struktur danych.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{ver}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Data/Compare/Plugins.pod
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorlib}/Data/Compare.pm
61 %dir %{perl_vendorlib}/Data/Compare
62 %{perl_vendorlib}/Data/Compare/Plugins
63 %{_mandir}/man3/Data::Compare.3pm*
64 %{_mandir}/man3/Data::Compare::Plugins*.3pm*
This page took 0.084195 seconds and 4 git commands to generate.