]> git.pld-linux.org Git - packages/perl-DNS-ZoneParse.git/blob - perl-DNS-ZoneParse.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DNS-ZoneParse.git] / perl-DNS-ZoneParse.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    DNS
6 %define pnam    ZoneParse
7 Summary:        DNS::ZoneParse - parse and manipulate DNS zone files
8 Summary(pl.UTF-8):      DNS::ZoneParse - analiza i obróbka plików stref DNS
9 Name:           perl-DNS-ZoneParse
10 Version:        0.99
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2bd59cbd7ec63343f024023e8360c015
17 URL:            http://search.cpan.org/dist/DNS-ZoneParse/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Storable >= 0.407
22 BuildRequires:  perl-Test-Simple >= 0.31
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module will parse a Zone File and put all the Resource Records
29 (RRs) into an anonymous hash structure. At the moment, the following
30 types of RRs are supported: SOA, NS, MX, A, CNAME, TXT, PTR. It could
31 be useful for maintaining DNS zones, or for transferring DNS zones to
32 other servers. If you want to generate an XML-friendly version of your
33 zone files, it is easy to use XML::Simple with this module once you
34 have parsed the zonefile.
35
36 %description -l pl.UTF-8
37 Ten moduł przetwarza pliki stref i umieszcza wszystkie rekordy zasobów
38 (Resource Records, w skrócie RR) w anonimowej strukturze będącej
39 tablicą asocjacyjną. Aktualnie obsługiwane są następujące rodzaje
40 rekordów: SOA, NS, MX, A, CNAME, TXT, PTR. Może to być przydatne przy
41 zarządzaniu strefami DNS albo przekazywaniu stref na inne serwery.
42 Jeśli chcemy wygenerować przyjazną dla XML wersję plików stref, można
43 łatwo użyć XML::Simple wraz z tym modułem zaraz po przeanalizowaniu
44 pliku strefy.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes
68 %{perl_vendorlib}/DNS/*.pm
69 %{_mandir}/man3/*
This page took 0.090791 seconds and 4 git commands to generate.