]> git.pld-linux.org Git - packages/perl-DBM-Deep.git/blob - perl-DBM-Deep.spec
- updated to 2.0017
[packages/perl-DBM-Deep.git] / perl-DBM-Deep.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         pdir    DBM
6 %define         pnam    Deep
7 Summary:        DBM::Deep - A pure Perl multi-level hash/array DBM
8 Summary(pl.UTF-8):      DBM::Deep - czysto perlowy moduł DBM dla wielopoziomowych haszy/tablic
9 Name:           perl-DBM-Deep
10 Version:        2.0017
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/DBM/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  92e950e8b99ee0c0d9a7fdefb36dc7d1
17 URL:            https://metacpan.org/dist/DBM-Deep
18 BuildRequires:  perl-Module-Build >= 0.28
19 BuildRequires:  perl-devel >= 1:5.8.4
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Digest-MD5 >= 1.00
24 BuildRequires:  perl-File-Temp >= 0.01
25 BuildRequires:  perl-IO-stringy >= 0.01
26 BuildRequires:  perl-Pod-Parser >= 1.3
27 BuildRequires:  perl-Scalar-List-Utils >= 1.14
28 BuildRequires:  perl-Test-Deep >= 0.095
29 BuildRequires:  perl-Test-Exception >= 0.21
30 BuildRequires:  perl-Test-Simple >= 0.88
31 BuildRequires:  perl-Test-Warn >= 0.08
32 %endif
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 A unique flat-file database module, written in pure Perl. True
38 multi-level hash/array support (unlike MLDBM, which is faked), hybrid
39 OO/tie() interface, cross-platform FTPable files, and quite fast. Can
40 handle millions of keys and unlimited hash levels without significant
41 slow-down. Written from the ground-up in pure Perl - this is NOT a
42 wrapper around a C-based DBM. Out-of-the-box compatibility with Unix,
43 Mac OS X and Windows.
44
45 %description -l pl.UTF-8
46 Jest to unikalny moduł bazy danych na płaskim pliku, napisany w
47 czystym Perlu. Ma prawdziwą obsługę wielopoziomowych haszy/tablic (w
48 przeciwieństwie do MLDBM, który jest oszukany), hybrydowy interfejs
49 obiektowy/tie(), wieloplatformowe pliki po FTP i jest dość szybki.
50 Może obsłużyć miliony kluczy i nieograniczoną liczbę poziomów tablic
51 asocjacyjnych bez znacznego spowolnienia. Napisany jest od początku w
52 czystym Perlu - NIE jest to wrapper na moduł DBM napisany w C. Jest
53 kompatybilny z Uniksami, Mac OS X oraz Windows.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         destdir=$RPM_BUILD_ROOT \
61         INSTALLDIRS=vendor
62
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/DBM/Deep.pod \
74         $RPM_BUILD_ROOT%{perl_vendorlib}/DBM/Deep/*.pod
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes README
82 %dir %{perl_vendorlib}/DBM
83 %{perl_vendorlib}/DBM/Deep.pm
84 %{perl_vendorlib}/DBM/Deep
85 %{_mandir}/man3/DBM::Deep*.3pm*
This page took 0.155435 seconds and 4 git commands to generate.