]> git.pld-linux.org Git - packages/perl-DBIx-Safe.git/blob - perl-DBIx-Safe.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBIx-Safe.git] / perl-DBIx-Safe.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DBIx
6 %define pnam    Safe
7 Summary:        DBIx::Safe - Safer access to your database through a DBI database handle
8 #Summary(pl.UTF-8):     
9 Name:           perl-DBIx-Safe
10 Version:        1.2.5
11 Release:        1
12 License:        bsd
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/T/TU/TURNSTEP/DBIx-Safe-1.2.5.tar.gz
15 # Source0-md5:  ca5abd5fec19da9d51e6312f6707c534
16 URL:            http://search.cpan.org/dist/DBIx-Safe/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-DBD-Pg >= 1.49
21 BuildRequires:  perl-DBI >= 1.49
22 BuildRequires:  perl-Module-Signature >= 0.50
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The purpose of this module is to give controlled, limited access to
29 an application, rather than simply passing it a raw database handle
30 through DBI. DBIx::Safe acts as a wrapper to the database, by only
31 allowing through the commands you tell it to. It filters all things
32 related to the database handle - methods and attributes.
33
34 # %description -l pl.UTF-8
35 # TODO
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes TODO
59 %{perl_vendorlib}/DBIx/*.pm
60 %{_mandir}/man3/*
This page took 0.087245 seconds and 4 git commands to generate.