]> git.pld-linux.org Git - packages/perl-DBIx-Recordset.git/blob - perl-DBIx-Recordset.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBIx-Recordset.git] / perl-DBIx-Recordset.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    DBIx
6 %define         pnam    Recordset
7 Summary:        DBIx::Recordset - abstraction and simplification of database access
8 Summary(pl.UTF-8):      DBIx::Recordset - abstrakcja i uproszczenie dostępu do bazy danych
9 Name:           perl-DBIx-Recordset
10 Version:        0.26
11 Release:        2
12 License:        GPL or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  fe008ad93b76ac0dea487f0c014842ee
16 URL:            http://search.cpan.org/dist/DBIx-Recordset/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-DBI
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 DBIx::Recordset is a perl module for abstraction and simplification of
27 database access.
28
29 The goal is to make standard database access
30 (select/insert/update/delete) easier to handle and independend of the
31 underlying DBMS. Special attention is made on web applications to make
32 it possible to handle the state-less access and to process the posted
33 data of formfields, but DBIx::Recordset is not limited to web
34 applications.
35
36 %description -l pl.UTF-8
37 DBIx::Recordset jest modułem Perla, umożliwiającym łatwy dostęp do baz
38 danych na wyższym, niż oferowany przez moduł DBI poziomie abstrakcji.
39
40 Celem jest uproszczenie typowych (odczyt/zapis/nadpisanie/usunięcie)
41 operacji na bazie danych, oraz uniezależnienie ich od stosowanego
42 DBMS. Szczególną uwagę poświęcono umożliwieniu aplikacjom internetowym
43 obsługi bezstanowego dostępu i przetwarzania danych z formularzy, ale
44 DBIx::Recordset nie jest ograniczony do WWW.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}::%{pnam}")' \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 mv -f eg/README README.eg
63
64 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65 cp -p eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README TODO README.eg
73 %{perl_vendorlib}/DBIx/*.pm
74 %dir %{perl_vendorlib}/DBIx/Recordset
75 %{perl_vendorlib}/DBIx/Recordset/*.pm
76 %{_mandir}/man3/*
77 %{_examplesdir}/%{name}-%{version}
This page took 0.070155 seconds and 4 git commands to generate.