]> git.pld-linux.org Git - packages/perl-DBIx-DataSource.git/blob - perl-DBIx-DataSource.spec
use generic url
[packages/perl-DBIx-DataSource.git] / perl-DBIx-DataSource.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4
5 %define         pdir    DBIx
6 %define         pnam    DataSource
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DBIx::DataSource - database-independent create and drop functions
9 Summary(pl.UTF-8):      DBIx::DataSource - niezależne od bazy danych funkcje do tworzenia i usuwania
10 Name:           perl-DBIx-DataSource
11 Version:        0.02
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  12d60ad75ceced40286d18fcdcb5a40b
18 URL:            http://search.cpan.org/dist/DBIx-DataSource/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module implements create_database and drop_database functions for
26 databases. It aims to provide a common interface to database creation
27 and deletion regardless of the actual database being used.
28
29 %description -l pl.UTF-8
30 Ten moduł jest implementacją funkcji create_database i drop_database
31 dla baz danych. Celem jego jest dostarczenie wspólnego interfejsu do
32 tworzenia i usuwania baz danych, niezależnego od używanej bazy.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{perl_vendorlib}/%{pdir}/*.pm
56 %{perl_vendorlib}/%{pdir}/%{pnam}
57 %{_mandir}/man3/*
This page took 0.056912 seconds and 4 git commands to generate.