]> git.pld-linux.org Git - packages/perl-DBIx-Class.git/blob - perl-DBIx-Class.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBIx-Class.git] / perl-DBIx-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DBIx
6 %define pnam    Class
7 Summary:        DBIx::Class - Extensible and flexible object <-> relational mapper
8 Summary(pl.UTF-8):      DBIx::Class - rozszerzalne i elastyczne wiązanie obiektów <-> relacji
9 Name:           perl-DBIx-Class
10 Version:        0.08250
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  4f65022a3d9480f3bb0610580dfdaf56
16 Patch0:         test.patch
17 URL:            http://search.cpan.org/dist/DBIx-Class/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Carp-Clan >= 6.0
22 BuildRequires:  perl-Class-Accessor-Grouped >= 0.10010
23 BuildRequires:  perl-Class-C3-Componentised >= 1.0009
24 BuildRequires:  perl-Class-Inspector >= 1.24
25 BuildRequires:  perl-Context-Preserve
26 BuildRequires:  perl-Config-Any >= 0.20
27 BuildRequires:  perl-DBD-SQLite >= 1.29
28 BuildRequires:  perl-DBI >= 1.605
29 BuildRequires:  perl-Data-Compare >= 1.22
30 BuildRequires:  perl-Data-Dumper-Concise >= 2.020
31 BuildRequires:  perl-Data-Page >= 2.00
32 BuildRequires:  perl-Devel-Cycle >= 1.10
33 BuildRequires:  perl-Devel-GlobalDestruction
34 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
35 BuildRequires:  perl-File-Temp >= 0.22
36 BuildRequires:  perl-JSON-Any >= 1.18
37 BuildRequires:  perl-MRO-Compat >= 0.09
38 BuildRequires:  perl-Module-Find >= 0.06
39 BuildRequires:  perl-Moo >= 1.004002
40 BuildRequires:  perl-Path-Class >= 0.16
41 BuildRequires:  perl-SQL-Abstract >= 1.73
42 BuildRequires:  perl-SQL-Abstract-Limit >= 0.13
43 BuildRequires:  perl-SQL-Translator >= 0.11006
44 BuildRequires:  perl-Scope-Guard >= 0.03
45 BuildRequires:  perl-Sub-Name >= 0.04
46 BuildRequires:  perl-Test-Deep
47 BuildRequires:  perl-Test-Exception >= 0.31
48 BuildRequires:  perl-Test-Memory-Cycle
49 BuildRequires:  perl-Test-Simple >= 0.92
50 BuildRequires:  perl-Test-Warn >= 0.21
51 BuildRequires:  perl-Text-CSV
52 BuildRequires:  perl-namespace-clean
53 %endif
54 BuildArch:      noarch
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # Only APR::UUID is available in PLD. And if it was we would still
58 # need only one of Data::UUID, Data::Uniqid, APR::UUID or UUID at any
59 # time to get full functionality
60 %define         _noautoreq_perl Data::Uniqid UUID APR::UUID JSON DBD::Multi DBIC::SQL::Abstract
61
62 %description
63 DBIx::Class is a SQL to OOP mapper, inspired by the Class::DBI
64 framework, and meant to support compability with it, while
65 restructuring the insides, and making it possible to support some new
66 features like self-joins, distinct, group bys and more.
67
68 It's currently considered EXPERIMENTAL - bring this near a production
69 database at your own risk! The API is *not* fixed yet, although most
70 of the primitives should be good for the future and any API changes
71 will be posted to the mailing list before they're committed.
72
73 %description -l pl.UTF-8
74 DBIx::Class to klasa odwzorowująca SQL na OOP, zainspirowana
75 szkieletem Class::DBI, mająca obsługiwać kompatibilność z nim, ale
76 restrukturyzując wnętrzności i umożliwiając obsługę niektórych nowych
77 możliwości, takie jak "self-join", "distinct", "group by" i inne.
78
79 Ten moduł jest aktualnie uważany za EKSPERYMENTALNY - zbliżać go do
80 baz produkcyjnych można tylko na własne ryzyko! API nie zostało
81 jeszcze ustalone, choć większość prymitywów powinna być dobra na
82 przyszłość i każda zmiana API jest wysyłana na listę dyskusyjną przed
83 zatwierdzeniem.
84
85 %package -n perl-SQL-Translator-DBIx-Class
86 Summary:        DBIx::Class schema parser and file producer
87 Summary(pl.UTF-8):      Narzędzie do analizy schematów i tworzenia plików DBIx::Class
88 Group:          Development/Languages/Perl
89
90 %description -n perl-SQL-Translator-DBIx-Class
91 This package contains SQL::Translator (sqlfairy) parser for
92 DBIx::Class::Schema objects and producer for DBIx::Class files.
93
94 %description -n perl-SQL-Translator-DBIx-Class -l pl.UTF-8
95 Ten pakiet zawiera analizator SQL::Translator (sqlfairy) dla obiektów
96 DBIx::Class::Schema oraz generator plików DBIx::Class.
97
98 %prep
99 %setup -q -n %{pdir}-%{pnam}-%{version}
100 %patch0 -p1
101
102 # requires installed DBIx::Class of same version
103 %{__mv} t/storage/dbic_pretty.t{,.disabled}
104
105 %build
106 %{__perl} Makefile.PL \
107         INSTALLDIRS=vendor
108 %{__make}
109
110 %{?with_tests:%{__make} test}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DBIx/Class/{Schema,ResultSet}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc Changes
125 %attr(755,root,root) %{_bindir}/*
126 %{perl_vendorlib}/DBIx/*.pm
127 %{perl_vendorlib}/DBIx/Class
128 %{_mandir}/man3/DBIx*
129 %{_mandir}/man1/dbicadmin.*
130
131 %files -n perl-SQL-Translator-DBIx-Class
132 %defattr(644,root,root,755)
133 %{perl_vendorlib}/SQL/Translator/Parser/*
134 %{perl_vendorlib}/SQL/Translator/Producer/*
135 %{_mandir}/man3/SQL*
This page took 0.079875 seconds and 4 git commands to generate.