3 %bcond_without tests # do not perform "make test"
6 %define pnam Class-TimeStamp
7 Summary: DBIx::Class::TimeStamp - automatically set timestamp fields in a table
8 Summary(pl.UTF-8): DBIx::Class::TimeStamp - automatyczne ustawianie pól znaczników czasu w tabeli
9 Name: perl-DBIx-Class-TimeStamp
13 License: GPL v1+ or Artistic
14 Group: Development/Languages/Perl
15 Source0: http://www.cpan.org/modules/by-authors/id/J/JS/JSHIRLEY/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5: e28818bb60b3927efcf0c5c76e44af08
17 URL: http://search.cpan.org/dist/DBIx-Class-TimeStamp/
18 BuildRequires: perl-devel >= 1:5.8.0
19 BuildRequires: rpm-perlprov >= 4.1-13
21 BuildRequires: perl(DBIx::Class::DynamicDefault)
22 BuildRequires: perl-DateTime
23 BuildRequires: perl-DBIx-Class
24 BuildRequires: perl-Class-Accessor-Grouped
25 BuildRequires: perl-DateTime-Format-MySQL
26 BuildRequires: perl-Time-Warp
29 BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32 Works in conjunction with InflateColumn::DateTime to automatically set
33 update and create date and time based fields in a table.
35 %description -l pl.UTF-8
36 Ten moduł działa w połączeniu z InflateColumn::DateTime, aby
37 automatycznie ustawiać w tabeli pola z datą i czasem uaktualnienia
41 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %{__perl} Makefile.PL \
48 %{?with_tests:%{__make} test}
51 rm -rf $RPM_BUILD_ROOT
54 DESTDIR=$RPM_BUILD_ROOT
57 rm -rf $RPM_BUILD_ROOT
60 %defattr(644,root,root,755)
62 %{perl_vendorlib}/DBIx/Class/*.pm