]> git.pld-linux.org Git - packages/perl-DBIx-Class-ResultSet-RecursiveUpdate.git/blob - perl-DBIx-Class-ResultSet-RecursiveUpdate.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBIx-Class-ResultSet-RecursiveUpdate.git] / perl-DBIx-Class-ResultSet-RecursiveUpdate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DBIx
6 %define pnam    Class-ResultSet-RecursiveUpdate
7 Summary:        DBIx::Class::ResultSet::RecursiveUpdate - like update_or_create - but recursive
8 #Summary(pl.UTF-8):     
9 Name:           perl-DBIx-Class-ResultSet-RecursiveUpdate
10 Version:        0.002
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-v%{version}.tar.gz
16 # Source0-md5:  f24a772e098223693737f9a3b5922343
17 URL:            http://search.cpan.org/dist/DBIx-Class-ResultSet-RecursiveUpdate/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(DBIx::Class::IntrospectableM2M)
22 BuildRequires:  perl-DateTime
23 BuildRequires:  perl-DBIx-Class >= 0.08011
24 BuildRequires:  perl-SQL-Translator >= 0.08
25 BuildRequires:  perl-SQL-Translator-DBIx-Class
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 You can feed the ->create method with a recursive datastructure
32 and have the related records created.  Unfortunately you cannot do
33 a similar thing with update_or_create - this module tries to fill
34 that void.
35
36 # %description -l pl.UTF-8
37 # TODO
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-v%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/DBIx/Class/ResultSet/*.pm
62 %{_mandir}/man3/*
This page took 0.062756 seconds and 4 git commands to generate.