]> git.pld-linux.org Git - packages/perl-Curses-UI.git/blob - perl-Curses-UI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Curses-UI.git] / perl-Curses-UI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Curses
6 %define         pnam    UI
7 Summary:        Curses::UI - a UI framework based on the curses library
8 Summary(pl.UTF-8):      Curses::UI - interfejs użytkownika oparty na bibliotece curses
9 Name:           perl-Curses-UI
10 Version:        0.9609
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Curses/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0dc4de85d94389b1d0eaaf36e804fc96
17 URL:            http://search.cpan.org/dist/Curses-UI/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Curses
22 BuildRequires:  perl-Term-ReadKey
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Curses::UI Perl module is a UI framework based on the curses library.
29 It can be used for the development of curses based user interfaces.
30
31 %description -l pl.UTF-8
32 Moduł Perla Curses::UI stanowi szkielet oparty na bibliotece curses.
33 Może służyć do konstruowania interfejsów użytkownika w oparciu o
34 bibliotekę curses.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 # fails with:
40 # Unable to get Terminal Size. The TIOCGWINSZ ioctl didn't work. The
41 # COLUMNS and LINES environment variables didn't work. The resize
42 # program didn't work.
43 # Alternatively we could add BR: X11 (which sounds a bit crazy for me)
44 #mv t/13notebook.t{,.blah)
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 # get rid of pod documentation
63 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Curses/UI/Tutorial.pod
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes CREDITS INSTALL README
71 %{perl_vendorlib}/Curses/*.pm
72 %{perl_vendorlib}/Curses/UI
73 %{_mandir}/man3/*
74 %dir %{_examplesdir}/%{name}-%{version}
75 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.0561700000000001 seconds and 4 git commands to generate.