]> git.pld-linux.org Git - packages/perl-Crypt-Random.git/blob - perl-Crypt-Random.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-Random.git] / perl-Crypt-Random.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    Random
7 Summary:        Crypt::Random - cryptographically secure, true random number generator
8 Summary(pl.UTF-8):      Crypt::Random - bezpieczny kryptograficznie, prawdziwy generator liczb losowych
9 Name:           perl-Crypt-Random
10 Version:        1.25
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5730c9d5acdd698790216d354ffb0513
17 Patch0:         %{name}-no_Class_Loader.patch
18 URL:            http://search.cpan.org/dist/Crypt-Random/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Math-Pari >= 2.001804
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Crypt::Random is an interface module to the /dev/random device found
29 on most modern Unix systems. The /dev/random driver gathers
30 environmental noise from various non-deterministic sources including
31 inter-keyboard timings and inter-interrupt timings that occur within
32 the operating system environment.
33
34 %description -l pl.UTF-8
35 Moduł Perla Crypt::Random stanowi interfejs do urządzenia /dev/random
36 znajdującego się w większości współczesnych systemów uniksowych.
37 Sterownik /dev/random gromadzi szum pochodzący z różnych
38 niedeterministycznych źródeł, włączając w to: przebiegi czasowe
39 klawiatury i przerwań występujące w systemie operacyjnym.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43 %patch0 -p1
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %attr(755,root,root) %{_bindir}/*
65 %{perl_vendorlib}/Crypt/Random.pm
66 %{perl_vendorlib}/Crypt/Random
67 #%%{perl_vendorlib}/Crypt/Random/Generator.pm
68 %{_mandir}/man3/*
This page took 0.082307 seconds and 3 git commands to generate.