]> git.pld-linux.org Git - packages/perl-Crypt-RandPasswd.git/blob - perl-Crypt-RandPasswd.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-RandPasswd.git] / perl-Crypt-RandPasswd.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    RandPasswd
7 Summary:        Crypt::RandPasswd Perl module - pronounceable passwords generator
8 Summary(pl.UTF-8):      Moduł Perla Crypt::RandPasswd - generator wymawialnych haseł
9 Name:           perl-Crypt-RandPasswd
10 Version:        0.02
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c266c6f10b59945d7dddc58ecef6e13b
17 URL:            http://search.cpan.org/dist/Crypt-RandPasswd/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This code is a Perl language implementation of the Automated Password
25 Generator standard, like the program described in "A Random Word
26 Generator For Pronounceable Passwords". This code is a re-engineering
27 of the program contained in Appendix A of FIPS Publication 181,
28 "Standard for Automated Password Generator".
29
30 %description -l pl.UTF-8
31 Ten moduł jest perlową implementacją standardu automatycznego
32 generatora haseł, takiego jak program opisany w "A Random Word
33 Generator For Pronounceable Passwords" (generator losowych słów na
34 potrzeby wymawialnych haseł). Ten kod jest ponowną implementacją
35 programu zawartego w załączniku A publikacji FIPS numer 181 "Standard
36 for Automated Password Generator".
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 # it may hang on a machine that does not receive enough random events
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/Crypt/RandPasswd.pm
62 %{_mandir}/man3/*
This page took 0.117865 seconds and 4 git commands to generate.