]> git.pld-linux.org Git - packages/perl-Crypt-RC6.git/blob - perl-Crypt-RC6.spec
- release 7
[packages/perl-Crypt-RC6.git] / perl-Crypt-RC6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    RC6
8 Summary:        Crypt::RC6 Perl module - RC6 block cipher encryption
9 Summary(pl.UTF-8):      Moduł Perla Crypt::RC6 - szyfr blokowy RC6
10 Name:           perl-Crypt-RC6
11 Version:        1.0
12 Release:        7
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6cd523b2ebfea33c66fc5f4252e88ce7
17 Patch0:         %{name}-endian.patch
18 URL:            http://search.cpan.org/dist/Crypt-RC6/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Crypt::CBC compliant RC6 block cipher encryption module. RC6 is an
25 evolutionary improvement of RC5, designed to meet the requirements of
26 the Advanced Encryption Standard (AES). This implementation requires
27 the use of a 16-, 24-, or 32-byte key and 16-byte blocks for
28 encryption/decryption. Twenty rounds are performed.
29
30 %description -l pl.UTF-8
31 Moduł jest zgodną z Crypt::CBC implementacją szyfru blokowego RC6. RC6
32 jest ewolucyjnym rozszerzeniem RC5, opracowanym na potrzeby AES
33 (Advanced Security Standard - standardu zaawansowanego
34 bezpieczeństwa). Ta implementacja wymaga użycia 16, 24, lub
35 32-bajtowego klucza i 16-bajtowych bloków do kodowania i dekodowania.
36 Wykonywane jest dwadzieścia kroków.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES README
63 %{perl_vendorarch}/Crypt/RC6.pm
64 %dir %{perl_vendorarch}/auto/Crypt/RC6
65 %{perl_vendorarch}/auto/Crypt/RC6/*.bs
66 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/RC6/*.so
67 %{_mandir}/man3/*
This page took 0.065511 seconds and 4 git commands to generate.