]> git.pld-linux.org Git - packages/perl-Crypt-RC6.git/blob - perl-Crypt-RC6.spec
- add CC to %{__make}
[packages/perl-Crypt-RC6.git] / perl-Crypt-RC6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    RC6
8 Summary:        Crypt::RC6 Perl module - RC6 block cipher encryption
9 Summary(pl.UTF-8):      Moduł Perla Crypt::RC6 - szyfr blokowy RC6
10 Name:           perl-Crypt-RC6
11 Version:        1.0
12 Release:        4
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6cd523b2ebfea33c66fc5f4252e88ce7
17 Patch0:         %{name}-endian.patch
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Crypt::CBC compliant RC6 block cipher encryption module. RC6 is an
24 evolutionary improvement of RC5, designed to meet the requirements of
25 the Advanced Encryption Standard (AES). This implementation requires
26 the use of a 16-, 24-, or 32-byte key and 16-byte blocks for
27 encryption/decryption. Twenty rounds are performed.
28
29 %description -l pl.UTF-8
30 Moduł jest zgodną z Crypt::CBC implementacją szyfru blokowego RC6. RC6
31 jest ewolucyjnym rozszerzeniem RC5, opracowanym na potrzeby AES
32 (Advanced Security Standard - standardu zaawansowanego
33 bezpieczeństwa). Ta implementacja wymaga użycia 16, 24, lub
34 32-bajtowego klucza i 16-bajtowych bloków do kodowania i dekodowania.
35 Wykonywane jest dwadzieścia kroków.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES README
62 %{perl_vendorarch}/Crypt/RC6.pm
63 %dir %{perl_vendorarch}/auto/Crypt/RC6
64 %{perl_vendorarch}/auto/Crypt/RC6/*.bs
65 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/RC6/*.so
66 %{_mandir}/man3/*
This page took 0.086103 seconds and 4 git commands to generate.