]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-Random.git/blob - perl-Crypt-OpenSSL-Random.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-OpenSSL-Random.git] / perl-Crypt-OpenSSL-Random.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-Random
7 Summary:        Crypt::OpenSSL::Random - accessing the OpenSSL pseudo-random number generator
8 Summary(pl.UTF-8):      Crypt::OpenSSL::Random - dostęp do generatora liczb pseudolosowych z OpenSSL
9 Name:           perl-Crypt-OpenSSL-Random
10 Version:        0.15
11 Release:        8
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bcde8d5a822c91376deda3c4f0c75fbe
17 URL:            https://metacpan.org/dist/Crypt-OpenSSL-Random
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-Crypt-OpenSSL-Guess >= 0.11
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Crypt::OpenSSL::Random provides the ability to seed and query the
27 OpenSSL library's pseudo-random number generator.
28
29 %description -l pl.UTF-8
30 Moduł Crypt::OpenSSL::Random daje możliwość zasilania oraz odpytywanie
31 generatora liczb pseudolosowych z biblioteki OpenSSL.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorarch}/Crypt/OpenSSL/Random.pm
58 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/Random
59 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/Random/Random.so
60 %{_mandir}/man3/Crypt::OpenSSL::Random.3pm*
This page took 0.061644 seconds and 3 git commands to generate.