]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-EC.git/blob - perl-Crypt-OpenSSL-EC.spec
- updated URL
[packages/perl-Crypt-OpenSSL-EC.git] / perl-Crypt-OpenSSL-EC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-EC
7 Summary:        Crypt::OpenSSL::EC - Perl extension for OpenSSL EC (Elliptic Curves) library
8 Summary(pl.UTF-8):      Crypt::OpenSSL::EC - moduł Perla do obliczeń na krzywych eliptycznych
9 Name:           perl-Crypt-OpenSSL-EC
10 Version:        1.32
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0ac9adc9e597cb492ed7255741426909
17 URL:            https://metacpan.org/dist/Crypt-OpenSSL-EC
18 BuildRequires:  openssl-devel >= 0.9.8i
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Crypt-OpenSSL-Bignum >= 0.04
24 %endif
25 Requires:       perl-Crypt-OpenSSL-Bignum >= 0.04
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides a standard (non-OO) interface to the OpenSSL EC
30 (Elliptic Curve) library. Some OO Calls are supported.
31 Most of the functions described in openssl/ec.h are supported.
32 It provides the Crypt::OpenSSL::EC class which defines some high level
33 functions and constants.
34
35 %description -l pl.UTF-8
36 Ten moduł dostarcza nieobiektowy interfejs programistyczny do
37 obliczeń na krzywych eliptycznych z blbioteki OpenSSL.
38 Dostępna jest wiekszość funkcji opisanych w pliku openssl/ec.h.
39 Klasa Crypt::OpenSSL::EC definiuje trochę wysokopoziomowych funkcji
40 i stałych.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorarch}/Crypt/OpenSSL/EC.pm
67 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/EC
68 %{perl_vendorarch}/auto/Crypt/OpenSSL/EC/autosplit.ix
69 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/EC/*.so
70 %{_mandir}/man3/Crypt::OpenSSL::EC.3pm*
This page took 0.109681 seconds and 4 git commands to generate.